Sentry Mode: Empty Files, Corrupt Video

  • SUPPORT THE SITE AND ENJOY A PREMIUM EXPERIENCE!
    Welcome to Tesla Owners Online, four years young! For a low subscription fee, you will receive access to an ad-free version of TOO. We now offer yearly memberships! You can subscribe via this direct link:
    https://teslaownersonline.com/account/upgrades

    SUBSCRIBE TO OUR YOUTUBE CHANNEL!
    Did you know we have a YouTube channel that's all about Tesla? Lots of Tesla information, fun, vlogs, product reviews, and a weekly Tesla Owners Online Podcast as well!

  • It's OK to discuss software issues here but please report bugs to Tesla directly at servicehelpna@teslamotors.com if you want things fixed.

Skione65

Top-Contributor
Joined
Apr 4, 2016
Messages
830
Location
Kentucky
Tesla Owner
Reservation
Country
Country
#41
So quick question....haven’t had quite the opportunity to play with Sentry Mode yet. Leaving it at the airport for a few days (armed) so we’ll see what happens. Anticipating 1mph draw/drain while gone. My question is....if you get an ‘alert’ due to Sentry Activation or a so called “triggered state”......how LONG does the alarm/horn sound? A specified duration then it quits? One minute? Two Minutes? OR do I have to physically get the alert......then enter the app and turn off or disable Sentry to stop the lights/horn from blaring? So as to not drain the battery?
Again I’m going to be out of town and not sure how it all works, do we deactivate to stop the Horn/lights and then ‘reactivate’ Sentry? Or does it time out after a specified time duration? What is the Protocol?

Regards,

Skione65
 

BluestarE3

Top-Contributor
Joined
Oct 12, 2017
Messages
567
Location
Norcal
Tesla Owner
Model 3
Country
Country
#42
So quick question....haven’t had quite the opportunity to play with Sentry Mode yet. Leaving it at the airport for a few days (armed) so we’ll see what happens. Anticipating 1mph draw/drain while gone. My question is....if you get an ‘alert’ due to Sentry Activation or a so called “triggered state”......how LONG does the alarm/horn sound? A specified duration then it quits? One minute? Two Minutes? OR do I have to physically get the alert......then enter the app and turn off or disable Sentry to stop the lights/horn from blaring? So as to not drain the battery?
Again I’m going to be out of town and not sure how it all works, do we deactivate to stop the Horn/lights and then ‘reactivate’ Sentry? Or does it time out after a specified time duration? What is the Protocol?

Regards,

Skione65
IIRC, someone posted in this or the other forum that the alarm sounds for 30 seconds and then stops and rearms itself.
 
Joined
Jun 9, 2018
Messages
15
Location
Chantilly
Tesla Owner
Model 3
Country
Country
#44
I love this sentry mode feature. I caught someone cleaning their car at work put a ding on my door. I know its a Nissan and have the person on video but haven't seen him since or the car. I guess he realized that I may be looking for him and started to park somewhere else. I wish the pillar cameras were also active as part of the sentry mode.
So I found the guy. He denied it initially but after watching the video all he could say was “oh!” 😀. Estimate came out to be $262 which he ended up paying.

Love this feature. Wish it used the pillar cameras and the backup cameras as well. I have a 256 SSD so it should be good enough to record min 2 weeks.
 

Needsdecaf

Top-Contributor
Joined
Dec 27, 2018
Messages
976
Location
The Woodlands, TX
Tesla Owner
Model 3
Country
Country
#45
Chalk me up to another one who's thumb drive bit the dust. Worked fine yesterday morning. I went to save a clip on the way home yesterday and noticed the gray X. Brought it inside and plugged it in, the computer said "corrupted" then asked if I wanted to fix, which I did. I was able to view the files from yesterday. A few blanks, but mostly there.

Plugged it in this morning and still the gray X.

Any good solution to this?
 

japhule

Active member
Joined
Apr 14, 2018
Messages
57
Location
Dallas, TX
Country
Country
#46
Chalk me up to another one who's thumb drive bit the dust. Worked fine yesterday morning. I went to save a clip on the way home yesterday and noticed the gray X. Brought it inside and plugged it in, the computer said "corrupted" then asked if I wanted to fix, which I did. I was able to view the files from yesterday. A few blanks, but mostly there.

Plugged it in this morning and still the gray X.

Any good solution to this?
Are you able to format or delete the files? My drive that went bad couldn't do either. Look into using SSD drives or dash friendly microsd cards with USB adapter (Samsung Pro Endurance) instead. What flash drive were you using?
 

Needsdecaf

Top-Contributor
Joined
Dec 27, 2018
Messages
976
Location
The Woodlands, TX
Tesla Owner
Model 3
Country
Country
#47
Are you able to format or delete the files? My drive that went bad couldn't do either. Look into using SSD drives or dash friendly microsd cards with USB adapter (Samsung Pro Endurance) instead. What flash drive were you using?
I'm able to delete them.

I was using a PNY 64GB drive I got at Office Depot. Nothing Fancy.

I should note, something I forgot. I haven't used Sentry Mode but once to try it out after I first got it. Yesterday while at lunch, I activated it. I notice that the last recordings on the drive were an hour or so of my car being driven to lunch and sitting in the parking lot. Then nothing, and now it doesn't work.

So i wonder if this is an issue with Sentry Mode, not the upgraded Tesla Cam?
 
Last edited:

Vegita2201

Member
TOO Supporting Member
Joined
Nov 30, 2018
Messages
9
Location
NJ
Tesla Owner
Model 3
Country
Country
#48
I think this (Green Blob on the side recordings) is a bug too. Seen it on both Model3s one with an ADATA SD600 256GB SSD and a SanDisk 1TB SSD. I do also share the opinion that it happens when the car is stationary for a period of time. I wonder whether it also has to do with putting the car into a sleep or lower power mode?
 

jsanford

Eloise the 3
Joined
May 23, 2016
Messages
192
Location
Seattle
Tesla Owner
Model 3
Country
Country
#49
Chalk me up to another one who's thumb drive bit the dust. Worked fine yesterday morning. I went to save a clip on the way home yesterday and noticed the gray X. Brought it inside and plugged it in, the computer said "corrupted" then asked if I wanted to fix, which I did. I was able to view the files from yesterday. A few blanks, but mostly there.

Plugged it in this morning and still the gray X.

Any good solution to this?
I’m on my fourth one. They seem to die every 2-8 weeks.
 

GDN

Moderator
Moderator
TOO Supporting Member
Joined
Oct 30, 2017
Messages
3,776
Location
Far North Dallas, TX
Tesla Owner
Model 3
Country
Country
#51
I bit the bullet and got an SSD off of Amazon. We shall see how long this lasts.
You won't regret it. $49.99 - Adata 256 GB SSD. Built in to a rugged case, has never even gotten warm on me. I've been running it 5 or 6 weeks.
 

gene1138

New Member
Joined
Oct 13, 2017
Messages
3
Location
NJ
Tesla Owner
Model 3
Country
Country
#52
Having similar issues. My left repeater would be 0 bytes and my front cam the bottom half of the image would be garbled. So far after getting 12.1.2 no longer getting 0 byte files and front cam seems fine. Though the left repeater sometimes gets the bottom 1/2 of image garbled pixels. Hopefully Tesla keeps working to fix the bugs in Sentry mode.
 
Joined
Apr 19, 2019
Messages
7
Location
Nashua NH
Tesla Owner
Reservation
Country
Country
#53
On this evening's half hour ride home, I got good recordings for a while, then zero length files:


Code:
-rwxr-xr-x 1 root root 29893460 May 14 10:30 2019-05-14_17-30-front.mp4
-rwxr-xr-x 1 root root 29882604 May 14 10:30 2019-05-14_17-30-left_repeater.mp4
-rwxr-xr-x 1 root root 29880060 May 14 10:30 2019-05-14_17-30-right_repeater.mp4
-rwxr-xr-x 1 root root 29901807 May 14 10:31 2019-05-14_17-31-front.mp4
-rwxr-xr-x 1 root root 29921494 May 14 10:31 2019-05-14_17-31-left_repeater.mp4
-rwxr-xr-x 1 root root 29623349 May 14 10:31 2019-05-14_17-31-right_repeater.mp4
-rwxr-xr-x 1 root root 29816909 May 14 10:32 2019-05-14_17-32-front.mp4
-rwxr-xr-x 1 root root 29637459 May 14 10:32 2019-05-14_17-32-left_repeater.mp4
-rwxr-xr-x 1 root root 29835648 May 14 10:32 2019-05-14_17-32-right_repeater.mp4
-rwxr-xr-x 1 root root 29679768 May 14 10:33 2019-05-14_17-33-front.mp4
-rwxr-xr-x 1 root root 30018545 May 14 10:33 2019-05-14_17-33-left_repeater.mp4
-rwxr-xr-x 1 root root 29984971 May 14 10:33 2019-05-14_17-33-right_repeater.mp4
-rwxr-xr-x 1 root root 29952685 May 14 10:34 2019-05-14_17-34-front.mp4
-rwxr-xr-x 1 root root 29720103 May 14 10:34 2019-05-14_17-34-left_repeater.mp4
-rwxr-xr-x 1 root root 29550191 May 14 10:34 2019-05-14_17-34-right_repeater.mp4
-rwxr-xr-x 1 root root 29848400 May 14 10:35 2019-05-14_17-35-front.mp4
-rwxr-xr-x 1 root root 29797354 May 14 10:35 2019-05-14_17-35-left_repeater.mp4
-rwxr-xr-x 1 root root 29840853 May 14 10:35 2019-05-14_17-35-right_repeater.mp4
-rwxr-xr-x 1 root root 29767032 May 14 10:36 2019-05-14_17-36-front.mp4
-rwxr-xr-x 1 root root 29774106 May 14 10:36 2019-05-14_17-36-left_repeater.mp4
-rwxr-xr-x 1 root root 29634318 May 14 10:36 2019-05-14_17-36-right_repeater.mp4
-rwxr-xr-x 1 root root  3276800 May 14 10:37 2019-05-14_17-37-front.mp4
-rwxr-xr-x 1 root root        0 May 14 10:37 2019-05-14_17-37-left_repeater.mp4
-rwxr-xr-x 1 root root        0 May 14 10:37 2019-05-14_17-37-right_repeater.mp4
-rwxr-xr-x 1 root root        0 May 14 10:38 2019-05-14_17-38-front.mp4
-rwxr-xr-x 1 root root        0 May 14 10:38 2019-05-14_17-38-left_repeater.mp4
-rwxr-xr-x 1 root root        0 May 14 10:38 2019-05-14_17-38-right_repeater.mp4
-rwxr-xr-x 1 root root        0 May 14 10:39 2019-05-14_17-39-front.mp4
-rwxr-xr-x 1 root root        0 May 14 10:39 2019-05-14_17-39-left_repeater.mp4
-rwxr-xr-x 1 root root        0 May 14 10:39 2019-05-14_17-39-right_repeater.mp4
-rwxr-xr-x 1 root root        0 May 14 10:40 2019-05-14_17-40-front.mp4
-rwxr-xr-x 1 root root        0 May 14 10:40 2019-05-14_17-40-left_repeater.mp4
-rwxr-xr-x 1 root root        0 May 14 10:40 2019-05-14_17-40-right_repeater.mp4
-rwxr-xr-x 1 root root        0 May 14 10:41 2019-05-14_17-41-front.mp4
-rwxr-xr-x 1 root root        0 May 14 10:41 2019-05-14_17-41-left_repeater.mp4
-rwxr-xr-x 1 root root        0 May 14 10:41 2019-05-14_17-41-right_repeater.mp4
-rwxr-xr-x 1 root root        0 May 14 10:42 2019-05-14_17-42-front.mp4
-rwxr-xr-x 1 root root        0 May 14 10:42 2019-05-14_17-42-left_repeater.mp4
-rwxr-xr-x 1 root root        0 May 14 10:42 2019-05-14_17-42-right_repeater.mp4

This is in a brand new Model 3 with 2019.12.1.2 and a SanDisk Extreme Go USB 3.1 Flash Drive 128GB (SDCZ800-128G-G46).

Next time, I'll check whether the drive feels hot.
 
Last edited:

DannyHamilton

Active member
Joined
Jul 9, 2018
Messages
39
Location
Chicagoland
Tesla Owner
Model 3
Country
Country
#54
Funny after corrupt and 0k files in the first week, Sentry had been working very well with all files perfect. In the last few days it is back to corrupt and 0k side repeater files.
It has to be some bug. Maybe a reboot helps.
I've definitely found that whenever I notice the 0-byte files or the bottom half of a clip green/corrupted, it seems to go away for a while if I reboot (I hold down the brake AND both scroll wheels until the Tesla logo appears).
 
Joined
Mar 3, 2019
Messages
11
Location
Illinois burbs
Tesla Owner
Model 3
Country
Country
#55
Not adding much value here, but will say I experience the same issues (0k files, pixelated/distorted/greenbar video) intermittently. I can't seem to determine a pattern as to when it works vs. when it doesn't. Hopefully this will get fixed at some point.
I guess the question I have to the forum is - does anyone not have these issues?
 

simpsonhomer

Active member
Joined
Aug 28, 2018
Messages
29
Location
Washington, DC
Tesla Owner
Model 3
Country
Country
#56
screen-shot-2019-05-17-at-12-00-02-am-png.25956


My numbers are all over the place but the one consistent thing is that my right repeater has far more 0-byte files than my left repeater. I did a little drive type/format experimentation but couldn't conclude anything.

My last pull was pretty good—only 2.11% of the files were bad (all from the right-side camera). But I have no idea what I'll get next time—I think Forrest Gump once said, "Sentry Mode files are like a box of chocolates..."

FYI, these are Mac/Linux commands you can run to count 0-byte files from the front, left, and right cameras, respectively (plus a count of all files). I run them from TeslaCam/SavedClips but you can run from TeslaCam if you want to also consider the continuous captures.

find . -type f -size 0 -name *front*.mp4 | grep -c mp4
find . -type f -size 0 -name *left*.mp4 | grep -c mp4
find . -type f -size 0 -name *right*.mp4 | grep -c mp4
find . -type f -name *.mp4 | grep -c mp4
 

Chip Douglas

Active member
Joined
Jan 2, 2019
Messages
108
Location
East Bay
Tesla Owner
Model 3
Country
Country
#57
Currently using a Sandisk Cruzer 64gb stick but always seem to be getting the "green blob" on one of the side cameras. I understand this may be the drive just being too slow. Is there a recommended drive that people are using out there?

Oh and I also noticed on a few occasions that the video would stop recording and the icon would turn to a gray X. Ejecting and re-inserting the stick seems to help. Not sure if this is a sign that the drive may be dying or a problem with the latest update???
 
Joined
Jul 25, 2018
Messages
10
Location
New Jersey
Country
Country
#58
I have the same issues with Sentry recordings - mostly issues with the Right repeater camera showing bottom half of screen as green and/or no video and many times, frozen repeater camera video etc. My assumption was my USB drive is too slow or something, but dashcam video seemed to behave better, but not perfect.
I actually made an appointment with Tesla Service to check the right camera as I also noticed that Auto Lane changes to the right seemed to abort more than when going left.

The Service tech told me that the Sentry camera issue is a firmware problem that they are aware of - so that will get fixed eventually.

My steering control module was showing errors which were causing the aborted lane changes.
They replaced the steering control module - glad I made that appointment!
 

GDN

Moderator
Moderator
TOO Supporting Member
Joined
Oct 30, 2017
Messages
3,776
Location
Far North Dallas, TX
Tesla Owner
Model 3
Country
Country
#59
I have the same issues with Sentry recordings - mostly issues with the Right repeater camera showing bottom half of screen as green and/or no video and many times, frozen repeater camera video etc. My assumption was my USB drive is too slow or something, but dashcam video seemed to behave better, but not perfect.
I actually made an appointment with Tesla Service to check the right camera as I also noticed that Auto Lane changes to the right seemed to abort more than when going left.

The Service tech told me that the Sentry camera issue is a firmware problem that they are aware of - so that will get fixed eventually.

My steering control module was showing errors which were causing the aborted lane changes.
They replaced the steering control module - glad I made that appointment!
Nice to have this confirmation. The description on your right camera is exactly what I have and I'm still seeing reported by others. Using a bigger/faster SSD drive though I rarely have any other kind of problems. Once in a blue moon a 0 byte file, but not often.
 

Rusty

Well-known member
Joined
Sep 9, 2017
Messages
205
Location
Ooltewah TN
Tesla Owner
Model S
Country
Country
#60
Well, last night my son was driving our Model 3. After dinner, he was backing out of his parking spot when a large SUV also started backing out. The SUV dented our rear passenger side door and then drove off. He followed them attempting to get their license plate number. He phoned, and I told him to tap the camera icon and call the police. When he got home we reviewed the camera files. Half of the files had no data. Of course, the ones of the accident were empty. The only useful file is the front camera recording of my son following the SUV in the parking lot. Here is a photo of the license plate. We can’t make out the state. I will upload the video later today. Anyone out there with better video editing able to read the state? Very frustrating. I may visit the parking lot again today to see if they come back. We are on vacation in Pigeon Forge, TN. There are a lot of out of state visitors here. I don’t think it is a TN plate.
 

Attachments