New bluetooth issues (previously rock solid)

  • SUPPORT THE SITE AND ENJOY A PREMIUM EXPERIENCE!
    Welcome to Tesla Owners Online, four years young! For a low subscription fee, you will receive access to an ad-free version of TOO. We now offer yearly memberships! You can subscribe via this direct link:
    https://teslaownersonline.com/account/upgrades

    SUBSCRIBE TO OUR YOUTUBE CHANNEL!
    Did you know we have a YouTube channel that's all about Tesla? Lots of Tesla information, fun, vlogs, product reviews, and a weekly Tesla Owners Online Podcast as well!

Milo

Active member
Joined
Apr 4, 2016
Messages
73
Location
Minnesota
Tesla Owner
Reservation
Country
Country
#1
Android phone, Moto Z2 Force. Car on 2019.20.1.

Have had the phone since I've had the car, about a year, and until the past few weeks, it has just worked. Every time (okay 99% of the time). I walk up to my car, it unlocks. I make calls, it works. Suddenly, it works as a key maybe 2/3 of the time. Sometimes cycling in and out of airplane mode works, sometimes not. Additionally, during calls my phone will connect and disconnect from the car repeatedly, going from bluetooth to not and back. I don't think this started with the most recent update.

Troubleshooting thoughts? Doesn't seem to happen with my wifes phone (iPhone 7s).
 

Mr. Spacely

Well-known member
TOO Supporting Member
Joined
Feb 28, 2019
Messages
369
Location
St. Petersburg, FL
Tesla Owner
Model 3
Country
Country
#2
It has largely been reported that iPhones work better with Tesla. Not sure why, but folks always speculate that Apple might buy Tesla...
 

skygraff

Top-Contributor
Joined
Jun 2, 2017
Messages
432
Location
Chicago IL
Tesla Owner
Model 3
Country
Country
#3
Could be the Bluetooth antenna in your phone. That was the problem with my iPhone shortly after getting the car last year.

Are you having issues with other Bluetooth functionality (e.g. headphone connectivity)?
 

Milo

Active member
Joined
Apr 4, 2016
Messages
73
Location
Minnesota
Tesla Owner
Reservation
Country
Country
#5
Could be the Bluetooth antenna in your phone. That was the problem with my iPhone shortly after getting the car last year.

Are you having issues with other Bluetooth functionality (e.g. headphone connectivity)?
Some, but not as much as with my car. Is there a way to test the bluetooth antenna?
 

webdriverguy

Top-Contributor
Joined
May 25, 2017
Messages
690
Location
CA
Tesla Owner
Model 3
Country
Country
#7
It has largely been reported that iPhones work better with Tesla. Not sure why, but folks always speculate that Apple might buy Tesla...
And this is based on which speculation? Musk and Tim have to get along, currently apple is not innovating at all.
 

skygraff

Top-Contributor
Joined
Jun 2, 2017
Messages
432
Location
Chicago IL
Tesla Owner
Model 3
Country
Country
#8
Some, but not as much as with my car. Is there a way to test the bluetooth antenna?
There may be but I don’t know.

For me, it just kept getting worse and I blamed the devices (car, headphones, door lock, etc.) until my phone’s gps also failed while on a long bike ride. I googled the symptoms and learned that the Bluetooth and gps share an antenna in the iPhone 6 and the issues noted could be related to a failure of the antenna or an orientation misalignment.

I took it to a local shop for direct diagnostics (opening it up and visually inspecting it) and they found one of the contacts had broken. Fortunately, they were able to get the part and repair it the same day. It violated the warranty but Apple wasn’t going to fix it anyway.

Basically, it got slightly worse until it seemed to pretty much fail but, as subtle as it was, I should’ve been more inclined to focus on the common intersection (the phone) rather than blame the individual peripherals.

Good luck!
 

ddatta

Active member
Joined
Nov 25, 2018
Messages
49
Location
New Jersey
Tesla Owner
Model 3
Country
Country
#9
I have the same problem after the 2019.20.1 update. Android Galaxy S8 loses connection intermittently. Was rock solid till 2019.16.2, never had a problem.
The recent problem are on the phone call connection, the phone Bluetooth regularly opens the car, without fail. The pairing of the voice and media device has become spotty.....
 
Joined
Jan 13, 2018
Messages
5
Location
Elk Grove, CA
Tesla Owner
Model 3
Country
Country
#10
Android phone, Moto Z2 Force. Car on 2019.20.1.

Have had the phone since I've had the car, about a year, and until the past few weeks, it has just worked. Every time (okay 99% of the time). I walk up to my car, it unlocks. I make calls, it works. Suddenly, it works as a key maybe 2/3 of the time. Sometimes cycling in and out of airplane mode works, sometimes not. Additionally, during calls my phone will connect and disconnect from the car repeatedly, going from bluetooth to not and back. I don't think this started with the most recent update.

Troubleshooting thoughts? Doesn't seem to happen with my wifes phone (iPhone 7s).
I had the same problem with my Samsung S8. I was able to unlock my car and make phone calls since July 2018, then it started failing, currently stuck at 2019.12.1.2. The car unlock was flawless, then it was flaky with about 90% success rate. Phone calls no longer worked - the bluetooth would toggle every 5 seconds from connected to not connected. Deleted the phone app and reinstalled, removed phone as key then added back, paired the bluetooth to the phone again, nothing worked. My wife's iPhone works fine with my car, and my S8 works fine with bluetooth headphones, so I don't know what the problem is, both seem to work, just not with each other. I got a new S9+ last night and now everything is working again.
 

ddatta

Active member
Joined
Nov 25, 2018
Messages
49
Location
New Jersey
Tesla Owner
Model 3
Country
Country
#11
I had the same problem with my Samsung S8. I was able to unlock my car and make phone calls since July 2018, then it started failing, currently stuck at 2019.12.1.2. The car unlock was flawless, then it was flaky with about 90% success rate. Phone calls no longer worked - the bluetooth would toggle every 5 seconds from connected to not connected. Deleted the phone app and reinstalled, removed phone as key then added back, paired the bluetooth to the phone again, nothing worked. My wife's iPhone works fine with my car, and my S8 works fine with bluetooth headphones, so I don't know what the problem is, both seem to work, just not with each other. I got a new S9+ last night and now everything is working again.
My problems seems to have stopped after the 2019.20.4.2 update. I had similar problems with my S8, but now it seems to behave properly.
 

harrison987

Active member
Joined
Jun 30, 2018
Messages
157
Location
Los Angeles
Tesla Owner
Model 3
Country
Country
#12
I am still having issues with the Galaxy S8. has been 100% PERFECT for a year...then with the most recent updates...it is spotty. Sometimes it does not even recognize me leaving the car, and does not auto-lock. The biggest headache is the phone (voice) connection to the car, and contact list. It disconnects, connects, disconnects, etc...so it is almost impossible to have a phone conversation.

I assume this is an ongoing issue...though some people seem to be okay now?
 

Jim Brown

Active member
Joined
May 2, 2016
Messages
136
Location
Pensacola, FL
Tesla Owner
Model 3
Country
Country
#13
The only bluetooth issue I had was with phone calls. It was weird too. My wife and I have the same phone, Samsung, Galaxy S8+. Her phone connected flawlessly for phone calls whenever she was driving. Mine was spotty. On and off. On and off. I couldn't make or receive a call at all. That lasted about 4 or 5 months. Both our phones are configured the same for bluetooth. Then all of a sudden, after an update, my phone works perfectly. Still can't figure it out.
 

IPv6Freely

Go Leafs Go
TOO Supporting Member
Joined
Aug 8, 2017
Messages
214
Location
Fallbrook, CA
Tesla Owner
Model 3
Country
Country
#14
I'm having issues too. Unlocking the car is fine, but then sometimes when I put my foot on the brake I get the "tap key card to start car" message. It's intermittent and only happens about 10% of the time. I haven't yet tried waiting to see if eventually it figures out the phone is there, though. I assume it will eventually. But why it will unlock the car but not start it is beyond me. Only started since the last update (2019.20.4.2 66625e9)