Left Turn Signal - Not operating correctly

  • SUPPORT THE SITE AND ENJOY A PREMIUM EXPERIENCE!
    Welcome to Tesla Owners Online, four years young! For a low subscription fee, you will receive access to an ad-free version of TOO. We now offer yearly memberships! You can subscribe via this direct link:
    https://teslaownersonline.com/account/upgrades

    SUBSCRIBE TO OUR YOUTUBE CHANNEL!
    Did you know we have a YouTube channel that's all about Tesla? Lots of Tesla information, fun, vlogs, product reviews, and a weekly Tesla Owners Online Podcast as well!

Joined
Aug 1, 2017
Messages
24
Location
Los Angeles, CA
Tesla Owner
Model 3
Country
Country
#1
I have had a strange turn signal issue since I picked up my car last Thursday (8/23/2018). Model 3 AWD.

I have driven BMWs for 12 years, so the double turn signal position (3 and lock) is not new to me. But I think my car as a software issue. The right turn signal operates as it should. Soft upward click to get the lane change blinker and hard upward click to make a right turn. Blinker stays on until I make the 90 degree turn and rotate the steering wheel back and it turns off. But when I soft click down to initiate a left lane change the signal doesn't turn off unless I do a soft click to the right. It also does not reset if I do a hard click down (for a left turn)...it just stays on unless I click it upward. Has anyone else experience this??

I'm on version 2018.32.2 which was on the car when I picked it up. I have done a couple of screen restarts (holding down the 2 steering wheel buttons), but i can't seem to get a hard restarts to work (by holding down the brake pedal as well). Or maybe there isn't a way to tell if you have successfully rebooted the entire system with the brake, I don't know.

Thanks!
 

zosoisnotaword

Well-known member
Joined
Aug 28, 2017
Messages
260
Location
Alabama
Tesla Owner
Model 3
Country
Country
#2
Sounds like a unique issue with your car. Send your post over to service and also send them a time stamp of when you tried to use your left signal. They can potentially diagnose it remotely by looking at logs from that timeframe. I didn't get a response from the servicehelpna email address, but when I talked to an actual person from service a couple weeks later about my HVAC issue, they were able to pull up the email I had sent.
 

StevenL

New Member
Joined
Jul 22, 2018
Messages
4
Location
Portland, OR
Tesla Owner
Model 3
Country
Country
#3
I have an issue with one of my blinkers as well but it’s a little different. For me, it’s the right one. When I pull the stalk up to the first level, if often (but not always) won’t stay on for the three blinks and if I pull it up to the second level, it will stay on for only the three blinks or sometimes not at all. I need to really push it up with force to get it to stay on. The left blinker works well, haven’t seen any issues going in that direction.
 

Yuriy

New Member
Joined
Aug 28, 2018
Messages
1
Location
Los Angeles
Tesla Owner
Model 3
Country
Country
#4
We picked up our model 3 AWD Saturday 8/25 and have exactly same behavior with the left turn signal as OP. Definitely not a unique issue... Funny our car is spec’d exactly the same including color and has same version 2018.32.2 and was picked up in Marina del Rey
 
Joined
Aug 1, 2017
Messages
24
Location
Los Angeles, CA
Tesla Owner
Model 3
Country
Country
#5
We picked up our model 3 AWD Saturday 8/25 and have exactly same behavior with the left turn signal as OP. Definitely not a unique issue... Funny our car is spec’d exactly the same including color and has same version 2018.32.2 and was picked up in Marina del Rey
Ha! That's funny. Maybe it's a MSM plague!!! Let me know if you end up having anyone take a look at it. I am scheduled for a service visit at the Van Nuys location next week to fix a paint chip I found on delivery and plan to bring it up then.
 
Joined
Sep 4, 2018
Messages
1
Location
Los Angeles, CA
Tesla Owner
Model 3
Country
Country
#6
I have had a strange turn signal issue since I picked up my car last Thursday (8/23/2018). Model 3 AWD.

I have driven BMWs for 12 years, so the double turn signal position (3 and lock) is not new to me. But I think my car as a software issue. The right turn signal operates as it should. Soft upward click to get the lane change blinker and hard upward click to make a right turn. Blinker stays on until I make the 90 degree turn and rotate the steering wheel back and it turns off. But when I soft click down to initiate a left lane change the signal doesn't turn off unless I do a soft click to the right. It also does not reset if I do a hard click down (for a left turn)...it just stays on unless I click it upward. Has anyone else experience this??

I'm on version 2018.32.2 which was on the car when I picked it up. I have done a couple of screen restarts (holding down the 2 steering wheel buttons), but i can't seem to get a hard restarts to work (by holding down the brake pedal as well). Or maybe there isn't a way to tell if you have successfully rebooted the entire system with the brake, I don't know.

Thanks!
I'm having the same issue. Picked up mine Aug 24 and has been doing it since I picked it up. Any luck with yours?
 

Minusword

New Member
Joined
Sep 6, 2018
Messages
2
Location
New Jersey
Tesla Owner
Model 3
Country
Country
#8
I have had a strange turn signal issue since I picked up my car last Thursday (8/23/2018). Model 3 AWD.

I have driven BMWs for 12 years, so the double turn signal position (3 and lock) is not new to me. But I think my car as a software issue. The right turn signal operates as it should. Soft upward click to get the lane change blinker and hard upward click to make a right turn. Blinker stays on until I make the 90 degree turn and rotate the steering wheel back and it turns off. But when I soft click down to initiate a left lane change the signal doesn't turn off unless I do a soft click to the right. It also does not reset if I do a hard click down (for a left turn)...it just stays on unless I click it upward. Has anyone else experience this??

I'm on version 2018.32.2 which was on the car when I picked it up. I have done a couple of screen restarts (holding down the 2 steering wheel buttons), but i can't seem to get a hard restarts to work (by holding down the brake pedal as well). Or maybe there isn't a way to tell if you have successfully rebooted the entire system with the brake, I don't know.

Thanks!
Any update on your issue?
 
Joined
Aug 1, 2017
Messages
24
Location
Los Angeles, CA
Tesla Owner
Model 3
Country
Country
#9
I had a service appt set up for tomorrow, but since they're also going to be looking at a paint chip that I had on delivery they will need to keep the car overnight. They're out of loaners, so they pushed my appt to the 17th. The person that I called to change my appt yesterday afternoon said they're ordering me a new stalk. So maybe that's the issue? Feels like software, but as I said, I've restarted a couple of times to no avail. I'll update everyone once I learn more!
 

roarkrd

Active member
Joined
Aug 17, 2018
Messages
36
Location
Missouri
Tesla Owner
No
Country
Country
#11
I picked up my Model 3 today and have the same issue. It’s not a huge deal, but incredibly annoying, especially with how sensitive the turn signal is. Half the time I end up activating the right turn signal when trying to get the left off.
 

roarkrd

Active member
Joined
Aug 17, 2018
Messages
36
Location
Missouri
Tesla Owner
No
Country
Country
#12
I’ve noticed that the left signal seems to sometimes get “reactivated” when the wheel is turning back to center, which keeps it on instead of turning it off. I’ve also discovered that to cancel it out when it won’t turn off, I can just barely touch the turn signal from the bottom, without even enough pressure to move it up. I’m hoping they can get the mobile service team out to replace it soon, along with my UMC, which won’t open the charge port.
 
Joined
Sep 10, 2018
Messages
1
Location
Napa County
Tesla Owner
Model 3
Country
Country
#13
I have the same problem, noticed it immediately upon delivery 2 days ago, on September 8. It is very bothersome not to have the turn signal turn off like it is supposed to. So now what do I do?
 

roarkrd

Active member
Joined
Aug 17, 2018
Messages
36
Location
Missouri
Tesla Owner
No
Country
Country
#14
I have the same problem, noticed it immediately upon delivery 2 days ago, on September 8. It is very bothersome not to have the turn signal turn off like it is supposed to. So now what do I do?
I highly recommend reaching out to your Service Center. I emailed them and they set me up with their mobile service team. They just contacted me to verify the problem and said they should be out next week with a new steering module/control unit. They've all been very helpful.
 
Joined
Aug 30, 2018
Messages
3
Location
New Hampshire
Tesla Owner
Model 3
Country
Country
#15
Same here! Took delivery 9/6/18 on the east coast and my right turn signal turns fine, but the left becomes continuous at the first position instead of just the 3 blinks. I noticed that there is a point somewhere in between idle and the first position where it will do just the 3 blinks. It's like something is not adjusted right. The self-centering turn signal lever is a bit annoying anyway because when the signal gets stuck on the left blink on the highway, I have to lift it up to turn it off, but often overshoot and end up putting my right turn signal on.
 
Joined
Sep 10, 2018
Messages
2
Location
Seattle, WA
Tesla Owner
Model 3
Country
Country
#16
Same here guys. Picked up my Model 3 AWD on 9/7 and it started doing it from the first turn. Took me a while to figure out but left is not switching off (both “hard” and “soft” push), even after a 90 degree left turn and switching off is annoying as I have to switch on the right signal on and off to correct.

Would appreciate if anybody has an update for how this can be best fixed. Running version 2018.34.1.
 
Last edited:
Joined
Sep 10, 2018
Messages
1
Location
91505
Tesla Owner
Model 3
Country
Country
#17
Hey guys. I am having this exact same issue. I purchased a red back wheel drive Tesla model 3. The left turn signal stays on regardless of what I do. I thought I was doing something wrong and I just didn't know how to use the car. I can attest to the original poster, the right blinker works exactly as it should, but the left blinker will stay on regardless if I tap it lightly or go beyond the hump point. It also does not turn off when you make the left turn. I called it in and told me a part is needed (they said it was mechanical and not software related). My autopilot does not work either (I paid for this) only cruise control works. I picked up the car at Marina Del Rey September 8th, 2018.
 

roarkrd

Active member
Joined
Aug 17, 2018
Messages
36
Location
Missouri
Tesla Owner
No
Country
Country
#19
The service center told me it’s a hardware issue. They’re supposed to be coming out on the 19th to replace the steering control module. Fingers crossed it works because I’m tired of looking like a one man light show driving around town.
 
Joined
Sep 10, 2018
Messages
2
Location
Seattle, WA
Tesla Owner
Model 3
Country
Country
#20
Same here guys. Picked up my Model 3 AWD on 9/7 and it started doing it from the first turn. Took me a while to figure out but left is not switching off (both “hard” and “soft” push), even after a 90 degree left turn and switching off is annoying as I have to switch on the right signal on and off to correct.

Would appreciate if anybody has an update for how this can be best fixed. Running version 2018.34.1.
Update: I talked to my nearest service center who informed me it was the unit on the steering wheel column. They ordered a new unit and said they would send out a mobile service team to replace.