Delete Navigation History

  • SUPPORT THE SITE AND ENJOY A PREMIUM EXPERIENCE!
    Welcome to Tesla Owners Online, four years young! For a low subscription fee, you will receive access to an ad-free version of TOO. We now offer yearly memberships! You can subscribe via this direct link:
    https://teslaownersonline.com/account/upgrades

    SUBSCRIBE TO OUR YOUTUBE CHANNEL!
    Did you know we have a YouTube channel that's all about Tesla? Lots of Tesla information, fun, vlogs, product reviews, and a weekly Tesla Owners Online Podcast as well!

slasher016

Well-known member
Joined
Sep 12, 2017
Messages
384
Location
Cincinnati, Ohio
Country
Country
Tesla Owner
Model 3
#1
This may be a dumb question. But has anyone figured out how to delete navigation history? There's a handful of destinations I never traveled to but typed into to check it out, but they show up and I can't seem to find a way to remove them.
 

zosoisnotaword

Well-known member
Joined
Aug 28, 2017
Messages
269
Location
Alabama
Country
Country
Tesla Owner
Model 3
#2
This may be a dumb question. But has anyone figured out how to delete navigation history? There's a handful of destinations I never traveled to but typed into to check it out, but they show up and I can't seem to find a way to remove them.
Hold-click them and it will give you an option to delete.
 

GDN

Moderator
Moderator
TOO Supporting Member
Joined
Oct 30, 2017
Messages
4,340
Location
Far North Dallas, TX
Country
Country
Tesla Owner
Model 3
#5
It should work. I've deleted all my trips to brothels and crack houses.
Be careful as your SO can still watch on the app. Have to check on that setting to turn remote access off for a while. Don't forget to turn it back on before you get home. "Must have just been a glitch."
 

NJturtlePower

Living the Dream, Driving the Future!
TOO Supporting Member
Joined
Dec 19, 2017
Messages
1,277
Location
Flemington, NJ
Country
Country
Tesla Owner
Model 3
#7
Be careful as your SO can still watch on the app. Have to check on that setting to turn remote access off for a while. Don't forget to turn it back on before you get home. "Must have just been a glitch."
This response right here qualifies for all 7 post reactions... ;)