Broken "Build Details" for AWD-P with 20" wheels?

  • SUPPORT THE SITE AND ENJOY A PREMIUM EXPERIENCE!
    Welcome to Tesla Owners Online, four years young! For a low subscription fee, you will receive access to an ad-free version of TOO. We now offer yearly memberships! You can subscribe via this direct link:
    https://teslaownersonline.com/account/upgrades

    SUBSCRIBE TO OUR YOUTUBE CHANNEL!
    Did you know we have a YouTube channel that's all about Tesla? Lots of Tesla information, fun, vlogs, product reviews, and a weekly Tesla Owners Online Podcast as well!

marusan

Active member
Joined
Jul 8, 2016
Messages
35
Location
California
Country
Country
#1
I've written to Telsa (delivery<at>tesla.com) twice trying to find out if my order is accurate, and am trying to figure out whether I need to blow an hour in their phone queue, or this is an endemic problem for this configuration. Obviously, I've received no response.

My "Build Details" appear as follows:

Your Model 3 build details
  • Red Multi-Coat Paint
  • Carbon Fiber Spoiler
  • Premium Interior
  • Premium Black
  • Enhanced Autopilot
  • Full Self-Driving Capability
No mention of performance, or the 20" wheels. Others have posted their build details, and it shows a much more itemized list. The only indication is the price. If I go in to edit my order, the page is broken (lots of JavaScript "NaN" stuff), until I choose performance and the wheels again.

Any other performance orderers who choose the performance upgrade package seeing this, as well?
 
Last edited:

Mayhem

Active member
Joined
May 25, 2018
Messages
130
Location
USA
Tesla Owner
Model S
Country
Country
#2
Is this new? Maybe related, maybe not but my Edit Design link is back without me doing anything. It had been gone once I had an all green checklist.
 

marusan

Active member
Joined
Jul 8, 2016
Messages
35
Location
California
Country
Country
#3
Is this new? Maybe related, maybe not but my Edit Design link is back without me doing anything. It had been gone once I had an all green checklist.
Not new to me -- it's been that way since I ordered. I didn't have an edit link for a short while, but it appeared within a day.
 

Bokonon

Self-identified Teslaholic
Moderator
TOO Supporting Member
Joined
Apr 12, 2017
Messages
3,143
Location
Boston
Tesla Owner
Model 3
Country
Country
#4
Is this new? Maybe related, maybe not but my Edit Design link is back without me doing anything. It had been gone once I had an all green checklist.
The just rolled out a new release of MyTesla within the last hour or so, and based on what other people are reporting, it seems like they fixed the prematurely-disappearing "Edit Design" link bug...here is an example of someone who has completed the entire delivery checklist (all green checkmarks) and, as of this update, their Edit Design link has returned.
 

marusan

Active member
Joined
Jul 8, 2016
Messages
35
Location
California
Country
Country
#5
I went ahead and called Tesla this morning (888-51-TESLA). Took 30 minutes to get through to a very nice person named Jenna. She agreed it was an enigma. After about 20 minutes on the phone, they still hadn't figured out what was messed up with the order. She called me back about half an hour later and said, "well, we looked at it, and the spoiler is on it, so it *has* to be the performance version with 20" wheels." And that's all she could really tell.

Still no explanation, nor any fix (and don't even bother with a delivery estimate -- she just gave me the standard line about being contacted at some point). She did admit "there have been glitches." I think we knew that. Just hoping whatever's broken doesn't effectively throw me to the back of the line.