Black Screen... (reboot didn't help)

  • SUPPORT THE SITE AND ENJOY A PREMIUM EXPERIENCE!
    Welcome to Tesla Owners Online, four years young! For a low subscription fee, you will receive access to an ad-free version of TOO. We now offer yearly memberships! You can subscribe via this direct link:
    https://teslaownersonline.com/account/upgrades

    SUBSCRIBE TO OUR YOUTUBE CHANNEL!
    Did you know we have a YouTube channel that's all about Tesla? Lots of Tesla information, fun, vlogs, product reviews, and a weekly Tesla Owners Online Podcast as well!

Joined
Apr 26, 2018
Messages
5
Location
CA
Country
Country
Tesla Owner
Reservation
#1
So yesterday I dropped off the car at the window tinting place (car was also put into valet mode).
Shop called me and said the car was done. I went to pick up and immediately found the screen was dead/black. I was still able to put it into reverse or drive so the car was movable, but other than that nothing else was working.
Called Tesla Support and was given the choice of towing or driving to service center. I did not want to wait for the tow truck, and SC was about 7 miles away.
I drove the car to SC with no AC/screen/turn signal, in 85F in norcal... It was not a good idea... had to open my window so many times to get some fresh air at traffic stops.
They ran out of Tesla loaners so they gave me an Enterprise rental.
Got a text at 426pm and said the car would be completed by today, but then this morning got another text that the part would not arrive until next Monday.
Kind of frustrated, and don't know if this has anything to do with the tint shop (they did many Teslas though...)
I will keep updated throughout the process I guess.....
 

babula

Top-Contributor
TOO Supporting Member
Joined
Aug 26, 2018
Messages
430
Location
New York
Country
Country
Tesla Owner
Model 3
#2
So yesterday I dropped off the car at the window tinting place (car was also put into valet mode).
Shop called me and said the car was done. I went to pick up and immediately found the screen was dead/black. I was still able to put it into reverse or drive so the car was movable, but other than that nothing else was working.
Called Tesla Support and was given the choice of towing or driving to service center. I did not want to wait for the tow truck, and SC was about 7 miles away.
I drove the car to SC with no AC/screen/turn signal, in 85F in norcal... It was not a good idea... had to open my window so many times to get some fresh air at traffic stops.
They ran out of Tesla loaners so they gave me an Enterprise rental.
Got a text at 426pm and said the car would be completed by today, but then this morning got another text that the part would not arrive until next Monday.
Kind of frustrated, and don't know if this has anything to do with the tint shop (they did many Teslas though...)
I will keep updated throughout the process I guess.....
What was the issue?