Anyone having an issue with premium connectivity upgrade??

  • SUPPORT THE SITE AND ENJOY A PREMIUM EXPERIENCE!
    Welcome to Tesla Owners Online, four years young! For a low subscription fee, you will receive access to an ad-free version of TOO. We now offer yearly memberships! You can subscribe via this direct link:
    https://teslaownersonline.com/account/upgrades

    SUBSCRIBE TO OUR YOUTUBE CHANNEL!
    Did you know we have a YouTube channel that's all about Tesla? Lots of Tesla information, fun, vlogs, product reviews, and a weekly Tesla Owners Online Podcast as well!

Needsdecaf

Top-Contributor
Joined
Dec 27, 2018
Messages
1,307
Location
The Woodlands, TX
Country
Country
Tesla Owner
Model 3
#22
So I had completely forgotten about this upgrade. Everything was still working 100% on Friday. Didn't drive the car all weekend. Got in this morning and thought "hey, my map looks funny". Took a sip of coffee and remembered why. Found the email link, did the upgrade and immediately got a notice on my screen that I had premium connectivity. Also, got a notice through apple pay immediately that my card was charged. Great, I think.

Not great. I was listening to a podcast on my phone, but checked streaming and it was working. But no satellite, no traffic. I kept looking for the icons to activate them but nothing. Did the two button reset twice while stopped at lights, still nothing.

Hoping that after the car goes to sleep it will come back and be fine.

My Tesla account shows that my subscription is active, and shows a receipt for this month. Didn't really dive into the menus in the car that much.
 

Needsdecaf

Top-Contributor
Joined
Dec 27, 2018
Messages
1,307
Location
The Woodlands, TX
Country
Country
Tesla Owner
Model 3
#23
Follow up. When I went down to the car after verifying it had been asleep, nothing had changed. I navigated to streaming audio and it told me to connect to wifi, then I navigated to Spotify. All of a sudden the screen did a quick reboot. Came back on and it did another quick reboot and stayed on. I noticed on the maps that the satellite view wasn't on but I could see a sliver of traffic data. So I navigated to the maps and boom, satellite was back.

As of now, this is where I stand:
  • Sat map view - active
  • Traffic data view - active
  • Streaming music - active
  • Caraoke - active
  • Video streaming - not active
  • Browser - didn't check.
Strange that the video streaming didn't work.
 
Joined
Jan 22, 2020
Messages
3
Location
Los Angeles
Country
Country
Tesla Owner
Model 3
#26
All I know is that Spotify is really bad and always has trouble loading. Almost makes me wonder why the premium connectivity is worth paying for...
 

RickO2018

Active member
Joined
Mar 13, 2018
Messages
66
Location
Jekyll Island, Georgia
Country
Country
Tesla Owner
Model 3
#27
I noticed that upon getting into the car today that the satellite view was gone although I upgraded to premium connectivity over a week ago.....when I logged in to my Tesla account to check.....it showed "standard connectivity"......not sure why??? Here's the kicker.....when I try to upgrade again to premium connectivity...... I get an error saying something went wrong and to try again later......


Anyone else having this issue???
I had that "something went wrong" problem initially as well. Than I discovered my credit card's expiration date was set for the following month. Once I updated the credit card, I did not see the message again and the Premium Connectivity "Tax" went into effect!